Page comments http://www.hdrlab.org.nz/home/ http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_3357 On my Sam460ex i'm enjoying a radeon HD 6450 1GB, it is passively cooled. Cheap and fast. Sat, 10 May 2014 11:04:15 +1200 ikir http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_3357 http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_1937 @greenmeanie Does your Radeon X700 support AGP 2x? Or is it AGP 4x/8x only. If it's AGP 4x/8x only, then yes, you may have damaged something. The A1-XE has an AGP 2x slot, and 2x slots use a higher voltage than AGP 4x and 8x. So, 4x/8x AGP cards should NOT be put into an A1-XE. This is exactly why I have been using PCI cards instead of AGP. I should also add that the Radeon X1300 is the oldest card supported by the RadeonHD driver, so the X700 will not work (unless there is another driver that supports it that I don't know about). Sat, 17 Sep 2011 16:17:10 +1200 Hans http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_1937 http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_1936 I put a radeon x700 AGP card in my amiga g4 xe and it didn't post up? Can that card damage the MB? Sat, 17 Sep 2011 13:02:37 +1200 greenmeanie http://www.hdrlab.org.nz/projects/amiga-os-4-projects/radeonhd-driver/radeonhd-card-recommendations-for-amigaos-4-x/#PageComment_1936